Connesso ma il browser non naviga (Chrome, Explorer, Firefox), problema LSP

di | 27 Ottobre 2014

A volte a causa di applicazioni indesiderate che infestano i pc, si manifestano sintomi a dir poco strani. Capita così di ritrovarsi di fronte ad un computer con Windows 7 che, nonostante sia regolarmente connesso ad una rete Wifi, improvvisamente non naviga più con nessun browser: Chrome, Internet Explorer, Firefox o altri.

Non posso trattare tutte le possibili cause e neppure tutte le possibili soluzioni per una situazione del genere, né voglio guidarvi passo passo, ma vi racconto la soluzione di un singolo episodio, non proprio banale. Nello specifico il sintomo citato, farebbe in genere pensare ad un problema con i server DNS o di connettività ad Internet, evenienza molto frequente e facilmente risolvibile.

Nel caso in oggetto invece la connessione funzionava al 100% e pure i DNS, infatti aprendo una finestra del prompt dei comandi (esegui -> cmd [invio]-> ping nomedominio [invio]) venivano regolarmente effettuati i ping verso domini esterni.

Bene, dopo una scansione con il sempre insostituibile HijackThis ho scoperto che erano danneggiate le librerie LSP (Layered Service Provider). Si tratta di servizi che consentono l’accesso alle risorse di rete ad applicazioni di livello più alto. Probabilmente uno spyware o un’adware aveva fatto danni.

La soluzione che ho trovato e che vi potrebbe salvare da un’inevitabile formattazione nel caso della stessa situazione, è quella di utilizzare il tool LSPFix disponibile sul sito Cexx.org, esso effettua una diagnosi e può direttamente riparare il problema. Io l’ho scaricato al volo dallo smartphone, non potendo dal pc mal funzionante, e poi l’ho trasferito sul pc ripristinando la connessione.

Ovviamente, una volta tornati in rete conviene effettuare una pulizia con i classici tool di sicurezza. Io ho i miei preferiti, ma di questo magari vi parlerò un’altra volta.

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *